Информатика

Всё о сервере, форум!
Основы программирования
ИНФОРМАЦИОННО-РАЗВЛЕКАТЕЛЬНЫЙ ПОРТАЛ

ИНФОРМАТИКА: ЕГЭ, ТЕОРИЯ, ПРАКТИКА, ТЕСТЫ



Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии
ЕГЭ, ДОМАШНИЕ ЗАДАНИЯ > Черепашка, робот > Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии
 

Содержание заданий и решения
Example
Общий метод решения

Example
Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n, вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m, вызывающая изменение направления движения на m градусов по часовой стрелке.

(Вместо n и m должны стоять целые числа).

Запись:
Повтори 5 [Команда1 Команда2]
означает, что последовательность команд в квадратных скобках повторится 5 раз.

Какое число необходимо записать вместо n в следующем алгоритме:

Повтори 7 [Вперед 40 Направо n],

чтобы на экране появился правильный шестиугольник?

1) 30
2) 45
3) 50
4) 60





Example
Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n, где n ‑ целое число, вызывающая передвижение черепашки на n шагов в направлении движения.

Направо m, где m ‑ целое число, вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори 5 [Команда1 Команда2] означает, что последовательность команд в скобках повторится 5 раз. Исполнитель интерпретирует эту запись как одну команду.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 5 [Повтори 4 [Вперед 40 Направо 90] Направо 120]

Какая фигура появится на экране?

РЕШЕНИЕ:

Повтори 5 [Повтори 4 [Вперед 40 Направо 90] Направо 120]

Повтори 4 [Вперед 40 Направо 90] - квадрат ответ 2

Ответ: 2

 
При копировании материала с сайта активная ссылка обязательна!
Сайт управляется SiNG cms © 2010-2015